首页 > 代码库 > *HDU 1028 母函数
*HDU 1028 母函数
Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19589 Accepted Submission(s): 13709
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The
input contains several test cases. Each test case contains a positive
integer N(1<=N<=120) which is mentioned above. The input is
terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
Author
Ignatius.L
题意:
拆数共有多少总方案
代码:
1 /*//整数拆分模板 2 #include <iostream> 3 using namespace std; 4 const int lmax=10000; 5 //c1是用来存放展开式的系数的,而c2则是用来计算时保存的, 6 //他是用下标来控制每一项的位置,比如 c2[3] 就是 x^3 的系数。 7 //用c1保存,然后在计算时用c2来保存变化的值。 8 int c1[lmax+1],c2[lmax+1]; 9 int main() 10 { 11 int n, i, j, k ; 12 // 计算的方法还是模拟手动运算,一个括号一个括号的计算, 13 // 从前往后 14 while ( cin>>n ) 15 16 { 17 //对于 1+x+x^2+x^3+ 他们所有的系数都是 1 18 // 而 c2全部被初始化为0是因为以后要用到 c2[i] += x ; 19 for ( i=0; i<=n; i++ ) 20 21 { 22 c1[i]=1; 23 c2[i]=0; 24 } 25 //第一层循环是一共有 n 个小括号,而刚才已经算过一个了 26 //所以是从2 到 n 27 for (i=2; i<=n; i++) 28 29 { 30 // 第二层循环是把每一个小括号里面的每一项,都要与前一个 31 //小括号里面的每一项计算。 32 for ( j=0; j<=n; j++ ) 33 //第三层小括号是要控制每一项里面 X 增加的比例 34 // 这就是为什么要用 k+= i ; 35 for ( k=0; k+j<=n; k+=i ) 36 37 { 38 // 合并同类项,他们的系数要加在一起,所以是加法,呵呵。 39 // 刚开始看的时候就卡在这里了。 40 c2[ j+k] += c1[ j]; 41 } 42 // 刷新一下数据,继续下一次计算,就是下一个括号里面的每一项。 43 for ( j=0; j<=n; j++ ) 44 45 { 46 c1[j] = c2[j] ; 47 c2[j] = 0 ; 48 } 49 } 50 cout<<c1[n]<<endl; 51 } 52 return 0; 53 }
1 #include<bits\stdc++.h> 2 using namespace std; 3 int c1[123],c2[123]; 4 void solve() 5 { 6 for(int i=0;i<=120;i++) 7 { 8 c1[i]=1; 9 c2[i]=0; 10 } 11 for(int k=2;k<=120;k++) 12 { 13 for(int i=0;i<=120;i++) 14 for(int j=0;j+i<=120;j+=k) 15 c2[j+i]+=c1[i]; 16 for(int i=0;i<=120;i++) 17 { 18 c1[i]=c2[i]; 19 c2[i]=0; 20 } 21 } 22 } 23 int main() 24 { 25 int n; 26 solve(); 27 while(scanf("%d",&n)!=EOF) 28 { 29 printf("%d\n",c1[n]); 30 } 31 return 0; 32 }
*HDU 1028 母函数
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。