首页 > 代码库 > hdu 2084 & POJ 1163 数塔 (dp)

hdu 2084 & POJ 1163 数塔 (dp)

数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24626    Accepted Submission(s): 14814


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
技术分享
已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
 

Sample Output
30
 

Source
2006/1/15 ACM程序设计期末考试




解析:dp,用二维数组d[i][j]存数塔,maxsum[i][j]代表从i,j位置出发到终点所能走过的路径总和的最大值,由于只能向下、向右走,所以状态转移方程就是maxsum[i][j] = max( getsum(i+1, j), getsum(i+1, j+1) ) + d[i][j];还有一点就是利用记忆化搜索,当d[i][j]已经计算过了,就不用再计算了。



AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
using namespace std;
#define INF 0x7fffffff
#define LL long long
#define MID(a, b)  a+(b-a)/2
const int maxn = 100 + 10;

int maxsum[maxn][maxn], d[maxn][maxn];
int n;

int getsum(int i, int j){
    if(maxsum[i][j] != -1) return maxsum[i][j];          //记忆化,已经计算过了,直接返回即可
    if(i == n) maxsum[i][j] = d[i][j];                   //递归出口
    else maxsum[i][j] = max( getsum(i+1, j), getsum(i+1, j+1) ) + d[i][j];     //转移方程
    return maxsum[i][j];
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk

    int t;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        memset(d, 0, sizeof(d));
        memset(maxsum, -1, sizeof(maxsum));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=i; j++)
                scanf("%d", &d[i][j]);
        printf("%d\n", getsum(1, 1));
    }
    return 0;
}





hdu 2084 & POJ 1163 数塔 (dp)