首页 > 代码库 > POJ3046 Ant Counting 【母函数】
POJ3046 Ant Counting 【母函数】
Ant Counting
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 2924 | Accepted: 1170 |
Description
Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!
Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.
How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed?
While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:
3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}
Your job is to count the number of possible sets of ants given the data above.
Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.
How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed?
While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:
3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}
Your job is to count the number of possible sets of ants given the data above.
Input
* Line 1: 4 space-separated integers: T, A, S, and B
* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
Output
* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.
Sample Input
3 5 2 3 1 2 2 1 3
Sample Output
10
Hint
INPUT DETAILS:
Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?
OUTPUT DETAILS:
5 sets of ants with two members; 5 more sets of ants with three members
Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?
OUTPUT DETAILS:
5 sets of ants with two members; 5 more sets of ants with three members
Source
USACO 2005 November Silver
母函数版:344ms
#include <stdio.h> #include <algorithm> #include <string.h> using namespace std; const int mod = 1000000; const int maxn = 1002; const int maxm = 100002; int dp[maxm], arr[maxn], c1[maxm], c2[maxm]; int main() { int T, A, S, B, i, j, k, v, sum; while(scanf("%d%d%d%d", &T, &A, &S, &B) != EOF) { memset(arr, 0, sizeof(int) * (T + 1)); for(i = 0; i < A; ++i) { scanf("%d", &v); ++arr[v]; } memset(c1, 0, sizeof(int) * (B + 1)); memset(c2, 0, sizeof(int) * (B + 1)); c1[0] = 1; for(i = 1; i <= T; ++i) { for(j = 0; j <= B; ++j) for(k = 0; k <= arr[i] && k + j <= B; ++k) c2[j+k] = (c1[j] + c2[j+k]) % mod; for(j = 0; j <= B; ++j) { c1[j] = c2[j]; c2[j] = 0; } } for(sum = 0, i = S; i <= B; ++i) sum = (sum + c1[i]) % mod; printf("%d\n", sum); } return 0; }
POJ3046 Ant Counting 【母函数】
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。