首页 > 代码库 > hdu 4952 Number Transformation

hdu 4952 Number Transformation

Number Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 617    Accepted Submission(s): 313


Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
2520 10 2520 20 0 0
 

Sample Output
Case #1: 2520 Case #2: 2600
 

Source
2014 Multi-University Training Contest 8
 

题解及代码:

       这道题目在比赛时是打表看出来的规律,我把i,n/i,n暴力输出出来,看到当i*i>=n时,n/i不再发生变化,由于数据最大是10^10,所以我们每次最多计算10^5次,不会超时,因此我们每次最多计算到i*i>=n时就可以了。


#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    long long n,k;
    int cas=1;
    while(scanf("%I64d%I64d",&n,&k)!=EOF)
    {
        if(!n&&!k)
            break;
        for(long long i=1;i<=k;i++)
        {
            if(n%i)
            {
                long long t=n/i;
                t++;
                n=t*i;
            }
            if(i*i>=n)
            {
                n=(n/i)*k;
                break;
            }
        }
        printf("Case #%d: %I64d\n",cas++,n);
    }
    return 0;
}