首页 > 代码库 > HDU4952:Number Transformation

HDU4952:Number Transformation

Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
2520 10 2520 20 0 0
 

Sample Output
Case #1: 2520 Case #2: 2600
找规律= =
#include <stdio.h>

int main()
{
    __int64 a,b,cas=1,i,j;
    while(~scanf("%I64d%I64d",&a,&b),a+b)
    {
        i=2;
        while(i<=b)
        {
            if(a%i)
            {
                j=a/i+1;
                if(j<=i)
                {
                    a=j*b;
                    break;
                }
                a=i*j;
            }
            else
            {
                j=a/i;
                if(j<=i)
                {
                    a=j*b;
                    break;
                }
            }
            i++;
        }
        printf("Case #%I64d: %I64d\n",cas++,a);
    }
    return 0;
}