首页 > 代码库 > HDU - 4952 Number Transformation

HDU - 4952 Number Transformation

Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

Sample Input
2520 10 2520 20 0 0
 

Sample Output
Case #1: 2520 Case #2: 2600题意:给你个x,k次操作,对于第i次操作是:要找个nx,使得nx是>=x的最小值,且能整除i,求k次操作后的数
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
typedef __int64 ll;
using namespace std;

ll x, k;

int main() {
	int cas = 1;
	while (scanf("%I64d%I64d", &x, &k) != EOF && x+k) {
		ll tmp = x;
		for (ll i = 2; i <= k; i++) {
			tmp = tmp - tmp/i;
			if (tmp < i)
				break;
		}
		printf("Case #%d: %I64d\n", cas++, tmp*k);
	}
	return 0;
}