首页 > 代码库 > HDU 1754-I Hate It(线段树:单点更新,区间最值)

HDU 1754-I Hate It(线段树:单点更新,区间最值)

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39163    Accepted Submission(s): 15507


Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取‘Q‘或‘U‘) ,和两个正整数A,B。
当C为‘Q‘的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为‘U‘的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
5 6 1 2 3 4 5 Q 1 5 U 3 6 Q 3 4 Q 4 5 U 2 9 Q 1 5
 

Sample Output
5 6 5 9
继续线段树,感觉输入数据多的话用update建树好像效果不是太好,比别人慢了近1000MS,要在学习一下建树方法。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
using namespace std;
const int INF=1<<27;
const int maxn=2000500;
int maxx[maxn];
void update(int root,int l,int r,int p,int v)
{
	int mid=(l+r)/2;
	if(l==r) maxx[root]=v;
	if(l<r)
	{
		if(p<=mid) update(root*2,l,mid,p,v);
		else update(root*2+1,mid+1,r,p,v);
		maxx[root]=max(maxx[root*2],maxx[root*2+1]);
	}
}
int query_max(int root,int l,int r,int ql,int qr)
{
	int ans=-INF,mid=(l+r)/2;
	if(ql<=l&&qr>=r) return maxx[root];
	if(ql<=mid) ans=max(ans,query_max(root*2,l,mid,ql,qr));
	if(qr>mid) ans=max(ans,query_max(root*2+1,mid+1,r,ql,qr));
	return ans;
}
int main()
{
	char op;
	int n,m,ql,qr,i,v,p;
	while(scanf("%d%d",&n,&m)!=EOF)
    {
    	for(i=1;i<=n;i++)
		{
			scanf("%d",&v);
			update(1,1,n,i,v);
		}
		while(m--)
		{
			getchar();
			scanf("%c",&op);
			if(op=='Q')
			{
			  scanf("%d%d",&ql,&qr);
			  printf("%d\n",query_max(1,1,n,ql,qr));
			}
			else if(op=='U')
			{
				scanf("%d%d",&p,&v);
				update(1,1,n,p,v);
			}
		}
    }
	return 0;
}