首页 > 代码库 > 合并果子

合并果子

1840: 合并果子

Time Limit: 1 Sec  Memory Limit: 64 MB   64bit IO Format: %lld

Description

        在一个果园里,多多已经将所有的果子打了下来,而且按果子的不同种类分成了不同的堆。多多决定把所有的果子合成一堆。
        每一次合并,多多可以把两堆果子合并到一起,消耗的体力等于两堆果子的重量之和。可以看出,所有的果子经过n-1次合并之后,就只剩下一堆了。多多在合并果子时总共消耗的体力等于每次合并所耗体力之和。
        因为还要花大力气把这些果子搬回家,所以多多在合并果子时要尽可能地节省体力。假定每个果子重量都为1,并且已知果子的种类数和每种果子的数目,你的任务是设计出合并的次序方案,使多多耗费的体力最少,并输出这个最小的体力耗费值。
       例如有3种果子,数目依次为1,2,9。可以先将 1、2堆合并,新堆数目为3,耗费体力为3。接着,将新堆与原先的第三堆合并,又得到新的堆,数目为12,耗费体力为 12。所以多多总共耗费体力=3+12=15。可以证明15为最小的体力耗费值。

Input

第一行是一个整数n(1 <= n <= 10000),表示果子的种类数。
第二行包含n个整数,用空格分隔,第i个整数ai(1 <= ai <= 20000)是第i种果子的数目。

Output

包含一个整数,也就是最小的体力耗费值。输入数据保证这个值小于231

Sample Input 技术分享

3 1 2 9

Sample Output

15
水题,熟悉堆

//堆排序
#include<cstdio>
#include<iostream>
using namespace std;
int a[10010],asize,n;
void put(int x)
{
    a[++asize]=x;
    int next,now=asize;
    while(now>1)
    {
        next=now/2;
        if(a[next]>a[now])
            swap(a[next],a[now]);
        now=next;
    }
}
int gets()
{
    int ret = a[1];
    a[1]=a[asize--];
    int now=1;
    while(now*2<=asize)
    {
        int next = now*2;
        if(next<asize&&a[next]>a[next+1])next++;
        if(a[next]<a[now])swap(a[next],a[now]);
        now=next;
    }
    return ret;
}
int main()
{
    int n;
    while(cin>>n)
    {  int x;
        asize=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            put(x);
        }
        int ans=0;

        while(asize>1)
        {
            x=gets();
            x+=gets();
            put(x);
            //cout<<x<<" ";
            ans+=x;
        }
        cout<<ans<<endl;
    }
    return 0;
}

//优先队列
#include<iostream>
#include<queue>
using namespace std;
 int n;
priority_queue<int ,vector<int>,greater<int> >h; //优先队列
int main()
{

    while(cin>>n)
    { int x,ans=0,y;
        for(int i=1;i<=n;i++)
        {  cin>>x;
           h.push(x);
        }
        for(int i=1;i<n;i++)
        {
            x=h.top();h.pop();
            y=h.top();h.pop();
            x+=y;
            ans+=x;
            h.push(x);
        }
        h.pop();
        cout<<ans<<endl;
    }
    return 0;
}

合并果子